Slow Uploads
Incident Report for NALSAR Forums Status Page
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 04:58 UTC
Update
Issue Restricted to Uploads. Downloads not affected.
Posted Oct 20, 2020 - 14:31 UTC
Investigating
We are currently investigating this issue.
Posted Oct 20, 2020 - 08:47 UTC
This incident affected: NALSAR Forums Android Application (Uploads (Files) -Android) and NALSAR Forums Website (Uploads (Files)).